posts - 30,  comments - 0,  trackbacks - 0

  1.什么是proxychains

  在linux系统中有很多软件是不支持代理的,但是proxychains 却可以让不支持代理的软件

也能走代理通道,支持HTTP,HTTPS,SOCKS4,SOCKS5,等多种代理协议,而且还能配?#20040;?#29702;链

(可以理解成多重代理),可以说是安全渗透的神器!

  2.什么是“强加密”代理、

  “强加密”代理指的是使用的一重代理,二重代理,多重代理中有一个代理是“强加密”

类型的那么?#20040;?#29702;就是“强加密”代理。这样如果别人想要获得你的真实IP是很困难的。

Tor就属于一种“强加密”代理,但是由于国内环境我们必须要进行前?#20040;?#29702;,

所以我选择SSR+Tor的组合。

  3.在Kali上 proxychains有问题

  Kali?#31995;膒roxychains是3.*的版本,无法使用Tor代理。而在firefox中设?#20040;?#29702;却能成功。

使用必然是proxychains的原因。

  4.解决办法

  第一种办法:

  vi /etc/proxychains.conf

把socks5代理改成socks4即可

  如图

  

 

 

  但是呢,socks4和socks5还是有区别的

SOCKS代理与其他类型的代理不同,它只是简单地传递数据包,而并不关心是何种应用协议,既可以是HTTP请求,

所以SOCKS代理服务器比其他类型的代理服务器速度要快得多。

SOCKS代理又分为SOCKS4和SOCKS5

二者不同的是SOCKS4代理只支持TCP协议(即传输控制协议),而SOCKS5代理则既支持TCP协议又支持UDP协议

(即用户数据包协议),还支持各种身份验证机制、服务器端域名解析等。SOCK4能做到的SOCKS5都可得到,

但SOCKS5能够做到的SOCK4则不一定能做到,比如我们常用的聊天工具QQ在使?#20040;?#29702;时就要求用SOCKS5代理,

因为它需要使用UDP协议来传输数据

  第二个方法

卸载Kali?#31995;膒roxychains 安装proxychains-ng(proxychains的升级版),

下载地址:https://sourceforge.net/projects/proxychains-ng/files/

不建议使用命令行下载有点慢,建议浏览器下载。之后解压并在解压目?#21363;?#24320;命令行。

执行以下代码:

 

  ./configure --prefix=/usr --sysconfdir=/etc
  make && make install
  make install-config 

之后配?#20040;?#29702;链
vi /etc/proxychains.conf

配置完后 执行 proxychains firefox发现firefox代理正常
之后执行 proxyresolv www.google.com 发现报错了

 

看到libproxychains.so.3应该是3.*版本没有卸载干净,动态库没更新

解决方法如下

首先在Kali的计算机目录搜索 proxychains 看一下更新后的动态库在那个目录

  然后打开proxyresolv的配置文件

  vi /usr/bin/proxyresolv

 

把 LD_PRELOAD等号后面的路径改成proxychains4.so的路径 

 测试一下

 

没有报错!

 

 


 

posted on 2019-03-20 23:16 MaxBlackTime 阅读(...) 评论(...) 编辑 收藏

耐克篮球多少钱